The Australian Medical Association Limited and state AMA entities comply with the Privacy Act 1988. Please refer to the AMA Privacy Policy to understand our commitment to you and information on how we store and protect your data.

×

Search

×

As we develop new web applications we leverage the exciting developments in new web technologies. While we are delivering advanced features using these technologies this does mean that users of our sites will require the newest browser. We cannot guarantee that the web sites will work on all older web browsers.

So what do we support?

We will support the current and prior major release of Chrome, Firefox, Internet Explorer and Safari on a rolling basis. Each time a new version is released, we will begin supporting the update and stop supporting the third-oldest version.

As of September 1st 2017, we have discontinued supporting the following browsers and their predecessors: Chrome version 55, Firefox version 51, Internet Explorer 9, and Safari 8.

In these old browsers you may have trouble using certain advanced features in our latest web sites and eventually these sites may stop working entirely as web browser technology advances.

How do I update my browser?

AMA IT encourages you to get the latest version of your favourite browser or discuss this with your organization's IT department. There are many to choose from:

 As software platforms move to the web, these new browsers are more than just a modern convenience, they are a necessity for these new online experiences.